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Training Overview: Project Lifecycle vs. Training Modules 
 

• Day 1: Setup and Sales Module - Page 6 

• Day 2: Design and Documentation Module – Page 57 

• Day 3: Operations Module – Page 96 
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Day 1: Setup and Sales 
 

This training module is divided into four sessions. 

Session 1 

• Navigation Overview 

• Control Panel Overview 

• Setup and Configuration 

Session 2 

• Catalog Navigation and Concepts 

• Core Catalog Creation (sales focus) 

Session 3 

• Packages and Accessories 

• Catalog Management 

• From Scope and Budget to a D-Tools Project 

Session 4 

• Sales Reports 

• Project Revisions and Change Orders  
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Navigation Overview 
 

• Three main navigation options 

• Home page navigation ribbon (across the top) 

• Only available from the home page 

 
 

• D-Tools “Start” menu 

• Provides access to all features 

 

• Quick access menus (across the bottom) 

• Always available from the main application 

• Not available from the project editor 
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Control Panel Overview 
 

• What is the Control Panel? 

• The heart of the system, where global settings are found 

• Key Settings 

• Company Information 
• Users (Accounts) 
• User Sign-In Policies 
• Phases (Labor settings) 
• Component ID Format 
• Tax Settings 

• Workflow Rules 

• Multiple Currencies 

• Configurable Lists 

• Project Statuses 
• Order Statuses 
• Schedule Statuses 
• Contract Payments 

• Global Manufacturers and Categories List  
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Setup and Configuration 
 

• Setup Company Information 

• Create Users, Resources, Groups and Permissions 

• At a minimum, remove all ‘delete’ permissions for standard users 

• Enable User Sign-In Policies 

• Define Phases and Labor Rates 

• Used for simplifying labor calculations and adjustments 

• Key to defining labor for Tasks (covered on day 3) 

• Add Tax Settings 

• Consider Price Types 

• Allowing up to 12 sets of pricing for different clients, projects, etc. 

 

ACTIVITY 1.1 - SET UNIQUE COMPANY INFORMATION 

1. Click Start → Setup → Control Panel. 

2. From the Control Panel, double-click Company Information:   

3. Find the ‘Use only on this windows account’ radio button and select it. 

4. Now change any of the information to customize it for yourself. 

5. Click Save and Close.  
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ACTIVITY 1.2 - SET STRONG PASSWORD POLICY ACROSS SI AND PORTALS 

1. Click Start → Setup → Control Panel. 

2. From the Control Panel, double-click User Sign-In Policies:   

3. Find the ‘Require strong passwords’ option and check the box. 

4. Towards the bottom pf the window, find the Portals section and check both options.  This will assign 

the same user sign-in policies to Mobile Install and the Customer Portal. 

5. Click Save and Close. 

 

ACTIVITY 1.3 - SET GDPR DEFAULTS FOR EUROPEAN UNION 

1. Click Start → Setup → Control Panel.  

2. From the Control Panel, double-click User Sign-In Policies. 

3. Find the ‘Set GDPR defaults for European Union’ link and 

select it. 

4. Click Save and Close. 
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ACTIVITY 1.4 - SET SALES TAX AND USE TAX 

1. Click Start → Setup → Control Panel.  

2. From the Control Panel, double-click Tax Settings. 

3. To add tax rates to be applied in your Projects, click the link ‘Manage Taxes’. 

a. From the Manage Taxes window, click New -> Tax. 

b. In the New Tax pop-up, give the tax rate a name and set a percentage. 

c. Click Save.  A new rate is added. 

d. Clos the Manage Taxes window by clicking the X in the upper-right corner. 

4. The most common use of Sales Tax is to set ‘Taxes are the same for all taxable products and labor’.  

Leave this setting in place unless you need to apply unique tax rates to different types of products. 

5. If you change the previous setting, you can then apply unique tax rates to individual products and 

labor items in your Catalog. 

6. If you would like Use Tax to values to be included in calculations of margin/markup, check the box 

in the Use Tax section to ‘Include Use Tax in margin/markup calculations’.  When this setting is 

active, you can apply a tax rate for Use Tax to Catalog items. 

7. To save your settings, click Save and Close.  
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Catalog Navigation 
 

• The Catalog is divided into three sections 

• Products 

• Labor Items 

• Packages 

• Navigating your catalog is easier with the following tools 

• Quick Filters – Allow you to easily filter your results 

• Queries – Allow for more complex filtering of catalog data 

• Layouts – change the screen layout to show preferred data fields 

• Multiple standard layouts 

• Create custom layouts if desired 
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ACTIVITY 1.5 - EXPERIMENT WITH QUICK FILTERS 

1. From the Home tab of the Product Explorer click Quick Filter. While there are several 

options, Manufacturer or Category are both useful choices. Pick a filter to see further 

options. 

2. After selecting a filter, click one of the check boxes within the filter and then Apply. 

3. The Catalog view has been filtered to reflect your choice. Reset will remove the filter. 

 

ACTIVITY 1.6 - CREATE AND RUN A QUERY 

1. From the Home tab of the Product Explorer click Queries. 

2. With the queries interface now open, notice the ‘New 

Product Query 1’ listed in the Name field. Highlight 

that text and type ‘Added in Last 24 Hours’ for the 

query name. 

3. Click on the spot that reads ‘Click here to add a clause. The columns should read: 

a. And/Or: And 

b. Field: Created On 

c. Operator: >= 

d. Value: @Today - 1 

4. Click the disk icon to save the query. Click the red play icon to run the query.  
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ACTIVITY 1.7 - CREATE AND ACTIVATE A CUSTOM LAYOUT 

1. From the Product Explorer, click the Layouts tab. 

2. In the Custom Layouts section, click Manage. 

3. The Manage Custom Layout window opens. Click New. 

4. In the Name text box, type a name like ‘Sales Layout.’ 

5. From the available columns section, choose some fields to populate your layout. Add these fields: 

Manufacturer, Model, Category, Phase, Labor Hours, MSRP, Unit Cost and Unit Price. After selecting 

each field click the right-facing arrow. 

6. Now click Save and Close. 

7. To see your layout, click Custom from the Layouts section of the Layouts tab and select your layout 

from the list. 
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Catalog Concepts 
 

• Category Types 

• Equipment 

• Speakers 

• Wire 

• Labor 

• Most products will be identified as “Equipment” 

• Each Category Type has unique properties 

• Equipment/Speakers: dimensions, weight, power, BTU, I/O’s 

• Speakers: dispersion 

• Wire: diameter, start/end terminal, bulk wire (t/f), length 

• Labor: fixed price, phase based rate, hours, etc. 
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Catalog Creation 
 

• Create your Core Catalog 

• Enter products manually and review core data fields 

• Add products from the D-Tools Library 

• Import products from CSV (spreadsheet) 

• Update products from the Library 

• Add bulk cable items 

• Add labor line items 

 

ACTIVITY 1.8 - CREATE A PRODUCT MANUALLY IN THE CATALOG 

1. Click Start → Catalog → Manage Products. 

2. From the Product Explorer, click New. 

3. Choose ‘DTI’ from the Manufacturer list. 

4. In the Model field type a name like “Test [Your Initials] Equipment.” 

5. Select a Category. 

6. Step through other tabs and fields and populate values. 

7. Now click Save and Close.  
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ACTIVITY 1.9 - ADD A PRODUCT FROM THE D-TOOLS LIBRARY 

1. From the Product Explorer, find the Library group (Home tab) and 

click Add From. 

2. The Add Products from Library window opens. 

3. In the Manufacturers list on the left, choose a name or enter search text to find a Manufacturer. 

Note: If the manufacturer is a partner (  icon), you may see an information page about the 

manufacturer. If so, click on the icon. This will load a list of 

products. 

4. To download a product from those listed, click the download link adjacent to the item. 

5.  The chosen product has now been added to the Catalog. Click the ‘X’ in the upper-

right to close the window. 

6. Back in the Product Explorer, type the model of the product in the search box to find the item. 
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ACTIVITY 1.10 - IMPORT PRODUCTS FROM A CSV FILE 

1. Start by creating a simple product spreadsheet in Excel: 

a. Add at least two columns: Manufacturer and Model. 

b. Cost and Price columns are typically useful as well. 

c. Add a few items that include data for each column you created. 

d. Save the file in CSV format. 

2. From the SI Product Explorer click Tools → Import. 

3. Find the CSV file you created earlier, select it and click Open. 

4. The Map CSV File dialog will open. Verify that the columns from your CSV are mapped to SI fields. 

Click Map next to any fields that need to be mapped and choose the appropriate field. 

5. Click Next, then click Finish. The file will be processed and the Import Editor will open. 

6. Next check the filter section. The products you are importing should be 

listed when you click New. If not, stop here. Ask for assistance. 

7. Finally, click Import → New and in the Import dialog, click OK. 

  



D-Tools System Integrator 
 

 

 

 

 

 
© 2016-2018 D-Tools Inc. | Professional Services Group  Training Guide - 20 

ACTIVITY 1.11 - UPDATE PRODUCTS FROM THE LIBRARY 

1. Select the products you imported from CSV (Try a standard Windows Shift-Click or Ctrl-Click to 

make your selection.) 

2. From the Product Explorer Home tab select “Update From” in the Library section. 

3. SI will now attempt to match your products with items in the Library. One of three 

possible outcomes will be the result: 

a. A dialog opens showing the products with additional data available. 

b. A message stating the products are already up-to-date. 

c. A message stating the products were not found in the Library. 

4. If additional data is found, simply select Update and Close. The products are now up to date. 
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ACTIVITY 1.12 - CREATE A LABOR ITEM 

1. Click Start → Catalog → Manage Labor. 

2. From the Labor Explorer, click New. 

3. Choose ‘DTI’ from the Manufacturer list. 

4. In the Model field type a name like “Test [Your Initials] Labor.” 

5. Select ‘Labor’ as the Category. 

6. Add a subcategory if you like. 

7. On the Description tab, add a description if you like. 

8. On the Price tab make the following selections: 

a. Select the Variable check box. 

b. Choose the Use cost and price from phase radio button. 

c. Select a Phase. 

d. Enter a number for Labor Hours (the number can include decimal values.) 

9. Now click Save and Close.  
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Catalog Accessories 
 

• Accessories are simply Other Catalog Items 

• Accessories can be Products or Labor Items 

• Accessory Rules 

• Products can have accessories 

• Accessories cannot have accessories 

• Accessory Framework 

• Create an outline describing the typical accessories associated with a 

category of product 

• Speakers have brackets and wire 

• Equipment racks have rack bases, lacing bars, fan tops, etc. 

• TVs have mount options, HDMI cable options, HD Base-T options 

  



D-Tools System Integrator 
 

 

 

 

 

 
© 2016-2018 D-Tools Inc. | Professional Services Group  Training Guide - 23 

ACTIVITY 1.13 - ADD ACCESSORIES TO A PRODUCT IN THE CATALOG 

1. From the Product Explorer, find one of the items created earlier (use the search box.) 

2. Double-click on the chosen product to edit it. 

3. Click on the Accessories option. 

4. Click Add Products. 

5. Try using the search box to find an HDMI cable (type ‘HDMI Cable’.) 

6. Now click the Add button, not the Add and Close button. 

7. Next, select a different HDMI cable. 

8. This time click Add and Close. 

9. Your results should look like this: 

10. Uncheck the Recommend check box for one of the cables. This sets one as the default but you will 

still be prompted for both when adding the parent item to a project.  

11. Now click Save and Close. 
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Packages 
 

• Packages are like wrappers around products and labor items 

• Packages have a name and description 

• Add products and labor items 

• Treat packages like an item or assembly 

• Packages include options for product and labor discounting 

• Package contents can be displayed or hidden in client reports 

• Examples include: 

• Phone/Data Wall Plate 

• 7.1 Surround Sound Wiring Package 

• Network Headend 

• Equipment Rack Package 

• Large Format Wall Mount TV Installation Package 
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ACTIVITY 1.14 - CREATE A PREWIRE PACKAGE 

1. Click Start → Catalog → Manage Packages. 

2. From the Package Explorer, click New. 

3. In the New Package window, type a name and description for the package: 

a. Use a name like “[Your Initials] – Prewire Package.” 

b. The description should describe the contents of the package. 

4. In the Options section, check all boxes except Prompt 

Accessories.  

5. Under the Navigation section, choose Items. 

6. In the Items section choose Add Products. 

7. The Add Products window opens. Type ‘dti cable’ in the search box. This should filter the list to 

show only cables. 

8. Add a few cable choices by selecting a product and clicking Add. When adding your last item, click 

Add and Close. 

9. Now click Add Labor. 

10. In the Add Labor window, choose ‘BULK WIRE PULL’. Click Add and Close. 

11. Last, click Save and Close. 

  



D-Tools System Integrator 
 

 

 

 

 

 
© 2016-2018 D-Tools Inc. | Professional Services Group  Training Guide - 26 

ACTIVITY 1.15 - CREATE A ROOM SOLUTION PACKAGE 

1. From the Package Explorer, click New. 

2. In the New Package window, type a name and description for the package: 

a. Use a name like “[Your Initials] – Room Solution Package.” 

b. The description should describe the contents of the package. 

Note: If you need ideas for the type of package to create, double-click on an existing package and 

look at how it is built. 

3. In the Options section, check all boxes except ‘Ignore labor in 

products...’  

4. Under the Navigation section, choose Items. 

5. In the Items section choose Add Products. 

6. The Add Products window opens. Try using the search box or a Quick Filter to find products. Add 

products to your package. Keep in mind, some products might already have accessories like HDMI 

cables or network patch cables. When adding the last item, click Add and Close. 

7. Last, click Save and Close. 
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Catalog Management 
 

• Tools for managing the Product Catalog efficiently 

• Mass Update – update a field across many products simultaneously 

• Update Accessories – add or append accessories to a selected group of 

similar products 

• Find in Projects – find where a product is used in Projects 

• Find and Replace in Catalog – find where a product is used as an 

accessory or within a package and replace it with another product 

• Import/Export – export data to Excel, make changes and import results 

• Update From Library 
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ACTIVITY 1.16  - MAKE PRODUCT UPDATES WITH THE IMPORT/EXPORT TOOLS 

1. From the Product Explorer, select a few items (Ideally, items you have created.) 

2. Click on the Tools tab. Then click Export → Selected. 

3. The Export Products to CSV File window opens. It shows all the data fields that can be exported. 

Towards the top, select the Deselect All button. 

4. Then choose fields to export. You must include Manufacturer and Model, otherwise you will not be 

able to import the items later. Include a few columns for data you would like to change. Cost and 

Price are the most common choice. 

5. Click OK. The Save CSV File dialog opens. Click Save. The exported data will open in Excel. 

6. From Excel make changes to the data. Then save the file (make sure it is in CSV format.) 

7. Return to the Product Explorer. On the Tools tab, click Import. 

8. Browse to your CSV file and click Open. 
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Project Concepts 
 

• Key Project Data: 

• Client Information 

• Name and Contact Details 

• Project and Billing Address 

• Client Number (optional, manual entry) 

• Project Name 

• Project Number 

• Project Status (i.e. Estimating, Pending, Approved) 

• Project “Assigned To” 

• Start/End Date 

• Notes – use notes to briefly track changes 

• Resources Assigned 

• Custom Fields 

• Use the Information option to access this data 

• Accurate tracking of this data is used in Dashboards  
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Project Creation 
 

• Creating a D-Tools Project requires: 

• Customer Information 

• Project Name 

• Building a Bill of Materials (BOM) typically requires: 

• Scope: What the customer wants 

• Budget: How much the customer is willing to spend 

• Why do I need a scope and budget? 

• The scope of work becomes part of the proposal and describes the 

project. It provides a narrative that is missing from a simple parts list 

• A budget helps prevent you from presenting a proposal that shocks your 

client 

• What else might be helpful? 

• Architectural drawings 

• Lighting design drawings 
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ACTIVITY 1.17 - CREATE A NEW PROJECT WITH A NEW CLIENT 

1. Starting from the Project Explorer, click New → Project. The New Project Wizard opens. 

2. To create a project, two pieces of information are required: a client and a project name. Click the 

Create Client button and select New. This opens the New Client window. 

3. In the Navigate section, click Contacts. Then click New → New Contact. 

4. In the New Contact window, start by entering a name, phone number and email address. 

5. Next click Addresses and enter address information. Click Save and Close. 

6. Now back in the New Client window, click Create as Client. 

7. A message about overwriting Client and address information will pop-up. Click Yes. Then click Save 

and Close. The New Client window will close and the information entered will populate the 

appropriate fields in the New Project Wizard. 

8. In the Project Name field, type a name for your project (something you will remember.) 

9. Nothing else is required to create the project and open it for editing. 

10. Finally, click Save to open your project. 
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Project Editor 
 

• Assemble and organize the BOM 

• Add Locations 

• Identify Systems 

• Add a Scope of Work 

• Add Products and/or Packages 

• Add Specialty Labor 

• Review and analyze your results 

• UI tools to help you identify problems 

• Views to help you understand what you have built 

• Make Product and Labor Adjustments 

• Phase Difficulty Factor – adjust labor quickly 

• Price Adjustments – percentage of product and/or labor 

• Alternates - different products that fulfill the same scope requirement 

• Optional – show options that add to the scope  
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ACTIVITY 1.18 - ADD LOCATIONS TO YOUR PROJECT 

1. Starting with your project open in the Project Editor, click the Settings tab, then choose Locations. 

2. To add locations from the list of locations, click Add → Locations. From the Add Locations window, 

check off location names and then choose Save and Close. 

3. To create new locations of your own naming, click New → Location. Type a location name. 

4. To create a Sub Location, select a location in your list, then click Add (or New) → Sub Location. Type 

it in or pick from the list. 

5. When you are done adding locations, click Save and Close. 

 

ACTIVITY 1.19 - ADD SYSTEMS TO YOUR PROJECT 

1. Adding Systems works much like adding Locations. From the Settings tab, choose Systems. 

2. To add Systems, click either Add or New to pick from the list or type in a new system name. 

3. When you are finished, click Save and Close. 
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ACTIVITY 1.20 - ADD A SCOPE OF WORK 

1. From the Project Editor Home tab, click Scope of Work.  

2. In the Manage Scope of Work window there are two methods for adding a Scope of Work: 

a. You can type directly into the large text box. 

b. Or, under Format, you can select the radio button ‘Scope of Work is in RTF format.’ This 

allows you to attach a scope of work created in Word and saved in RTF format. The attached 

file will become part of the project. 

3. When complete, click Save and Close. 

 

ACTIVITY 1.21 - ADD PRODUCTS TO YOUR PROJECT 

1. To add products to a project, start by selecting a location and system from the lists on the right 

side of the Project Editor window. 

2. For quick access to a ‘mini catalog’, use the pop-out Product Explorer found along the left edge of 

the Project Editor window. Click it and it will open. 

3. From this pop-out window you have access to a search box, Quick Filters, etc. Use them to search 

for products. 

4. Select a product. Then click Add to Project. The product will be added to the location and system 

you designated in Step 1.  
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ACTIVITY 1.22 - ADD PACKAGES TO YOUR PROJECT 

1. Just like adding products, start by selecting a location and system from the list. 

2. Click on the Package Explorer along the left side. It will pop open. 

3. Search for a package. Select one and click Add to Project. 

 

ACTIVITY 1.23 - USE THE VIEW TOOLS TO ANALYZE YOUR PROJECT 

1. In your project, click View, then click Phase under the Summary section. This will change your view 

to a Project Summary.   

2. Clicking on any Phase name will drill down into the Phase and show you a summarized list of 

products and labor in that Phase. 

3. Clicking on any product will drill down and show you all the locations of that product. 

4. Click Back (next to View) to return to the previous view. 
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ACTIVITY 1.24 - ADJUST LABOR WITH PHASE DIFFICULTY FACTOR 

1. In your project, click Settings, then click Phases. The Manage Project Phases window will open. 

2. Click on the Rough-in Phase on the left. The details of the selected Phase are now shown. 

3. Find the Base Labor row and scan across to the Difficulty (%) field. By default, it is 100%. This means 

that for every hour assigned to a product in this Phase, one hour of labor, at the defined rate, is 

added to the project. 

4. To increase your Rough-in labor by 10%, change the Difficulty to 110%, an increase of 10%. Do this 

now. After the adjustment, this means that for every hour assigned to a product in this Phase, 1.1 

hours of labor, at the defined rate, is added to the project. 

5. This change, if saved, will immediately reflect an increase of 10% for labor in the Rough-in Phase. 

This increase will be in hours and dollars. 

Note: Setting Difficulty (%) to a value less than 100% will reduce the hours and dollars. 

 

ACTIVITY 1.25 - ADJUST TOTAL PRODUCT AND/OR LABOR PRICING WITH PRICE ADJUSTMENTS 

1. In your project, click Settings, then click Price Adjustments. The Manage Project Price Adjustments 

window will open. 

2. Adding a positive or negative number in any of the adjustment fields will increase or decrease total 

pricing by that percentage. These are global for Product, Miscellaneous Parts, and Labor. 

3. Adjust a value and then run a Proposal report. Look at the Project Summary to see the changes. 

Note: Price Adjustments can be renamed in reports to be used for other expenses (think freight).  
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Project Sales Reports 
 

• Run reports for internal review 

• Project Summary 

• Detailed Cost Summary 

• Gross Profit 

• Use the Quote report for small projects and box sales 

• Run reports to create a proposal package 

• Cover Page 

• Scope of Work 

• Proposal Summary 

• Line Item Detail or Proposal 

• Contract 

• Create a Report Group 

• Dashboards for Sales Insights 

• Sales Pipeline 

• Sales Won 

• Sales Volume  
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ACTIVITY 1.26 - RUN A PROJECT SUMMARY REPORT 

1. Click Reports. 

2. Click Project Summary in the Quick Reports section. 

Note: Quick Reports can be configured to run reports of your choosing under Report Settings. 

 

ACTIVITY 1.27 - RUN A DETAILED COST SUMMARY REPORT 

1. Click Reports → Management. 

2. Click the ‘+’ next to Detailed Cost Summary. 

3. Double-click the report definition named ‘By Phase’ 

 

ACTIVITY 1.28 - RUN THE COVER PAGE REPORT 

1. Click Reports → Client. 

2. Double-click Cover Page. 

 

ACTIVITY 1.29 - RUN THE SCOPE OF WORK REPORT 

1. Click Reports → Client. 

2. Double-click Scope of Work.  
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ACTIVITY 1.30 - RUN THE PROPOSAL SUMMARY REPORT 

1. Click Reports → Client. 

2. Click the ‘+’ next to Proposal Summary. 

3. Double-click the report definition named ‘By System.’ 

 

ACTIVITY 1.31 - RUN A LINE ITEM DETAIL REPORT 

1. Click Reports → Client. 

2. Choose a Line Item Detail report (Notice there are three versions.) 

3. Make sure to click the ‘+’ next to the report name and choose a definition. 

4. Double-click on the definition. 

 
ACTIVITY 1.32 - RUN A PROPOSAL REPORT 

1. Click Reports → Client. 

2. Choose a Proposal report (Notice there are nine standard versions.) 

3. Make sure to click the ‘+’ next to the report name and choose a definition. 

4. Double-click the definition. 
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ACTIVITY 1.33 - RUN THE CONTRACT REPORT 

1. Click Reports → Client. 

2. Double-click Contract. 

 

ACTIVITY 1.34 - CREATE AND RUN A REPORT DEFINITION 

1. From the main SI window click Start → Reports → Manage Reports. 

2. In the list of reports, click the ‘+’ next to the Client Reports category to expand the list of client 

reports. 

3. Find Proposal With Images. Right-click on this report and select New → Report Definition. 

4. In the Report Definition window, type a Description like ‘[Your Initials] - By System By Location – 

No Cover Page.’ This will be the name of the Report Definition in the list. 

5. Now, on the Grouping tab type ‘System’ on the first line and type 

‘Location’ on the next line. The results should look like this: 

6. Click on the Parameters tab and check the Hide Cover Page option. 

7. Click Save. 

8. To run this report definition, return to the Project Explorer. Use the Quick Access menus across the 

bottom of the window (Projects → Projects.) 

9. Select your project from the list. Click Reports → Client Reports. 

10. The Project Reports window opens. Click the ‘+’ next to the Proposal With Images report. 

11. Find you report definition and double-click it. Your report definition will run.  
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ACTIVITY 1.35 - CREATE AND RUN A REPORT GROUP 

1. From the Report Explorer (Start → Reports → Manage Reports) find the 

Group section and click New.  

2. The Add Report Grouping window opens. Type a Name and Description 

for your report group like ‘[Your Initials] – Proposal Report Group.’ 

3. In the Reports list on the left, click the ‘+’ next to Client Reports. 

4. Now add the Cover Page report by checking the box to the left of the report name. 

5. Add the Scope of Work (see step 4.) 

6. Click the ‘+’ next to the report called Proposal Summary. Then check the box next to the ‘By System’ 

definition. 

7. Next add the Proposal With Images report using the definition from the last activity: 

a. Click the ‘+’ next to the report called Proposal With Images. 

b. Then check the box next to the name of the definition you added. 

8. Last, add the Contract report (see step 4.) Click Save. 

9. To run this report group, return to the Project Explorer. Use the Quick Access menus across the 

bottom of the window (Projects → Projects.) 

10. Select your project from the list. Click Reports. 

11. From the Reports tab choose Other. 

12. The Project Reports window opens. Scroll to the bottom and expand Report Groups. 

13. Find your report group and double-click on it. The report group will run. 
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ACTIVITY 1.36 - RUN A VISUAL REPORT IN THE DASHBOARD 

14. From the D-Tools Home page (Start → Home Page), select Dashboards.  

15. From the Dashboard Explorer, click the arrow next to the ‘Sales Insights’ 

category on the left side of the screen. This will show several sales-focused reports. 

16. Double-click on ‘Sales (Pipeline)’. This will open a visual report grouped by Sales Rep (using the 

‘Assigned To’ field). 

17. Click the ‘Export’ button to save a copy as an image. This can be included in a report or other sales 

presentation. 

18. Explore other sales dashboards. Notice filter options related to dates, project status and project 

progress. 
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Project Revisions and Pre-Sale Workflow 
 

• What is a Project Revision? 

• SI manages snapshots of a project’s data called “Revisions” 

• Revisions are read only copies of the project at the moment they were 

created and are separate from the project data 

• Why store Project Revisions? 

• Revisions help users manage pre-sale workflow and present options to 

their customers 

• As a customer requests changes prior to contract, simply create a new 

revision, make the updates and issue a new proposal 

• The Revision “Compare” option tracks how Revisions differ 

• Revision comparisons show additions, deletions and changes 

• Reports can be run on this data to reflect the change 

• The project and revisions can be compared to see what is different 

between them 

• Comparisons can be project to revision or between two revisions  
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ACTIVITY 1.37 - CREATE A PROJECT REVISION AND MAKE SOME CHANGES 

1. Click Start → Projects → Manage Projects. 

2. Select your project from the list (single-click.) 

3. Below the list of projects, you will see six tabs. Click on Revisions, then click Create.  

4. The 

Create Revision dialog box opens. Click in the Notes text box and type a short description (the state 

of the project estimate before the revision.) Now click OK. 

5. You have saved a snapshot of the project in the current state. 

6. Now open your project (not the revision) and make some changes: 

a. Add a product. 

b. Delete a product. 

c. Replace a product. 

i. Select the product, right-click, choose Replace → Product. 

ii. Select a new product. 

7. Now you have a new version of the project to present as a proposal. 

8. Save and close your project (click disk icon, upper-left, ‘X’ upper-right.) 
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ACTIVITY 1.38 - COMPARE REVISIONS AND RUN A REPORT TO REFLECT THE DIFFERENCES 

1. Select your project from the list (single-click.) 

2. Verify the project is checked out to you. Your SI user name should be listed in the Checked Out To 

field in the project listing. If no name is listed, click Check Out from the command ribbon above. If 

another user name is listed, ask that user to check in the project (or ask for assistance). 

3. Below the list of projects, click on Revisions. 

4. Click Compare. 

5. The Project Revisions Comparison Selector opens, showing a listing of Revisions in the project. You 

will likely only see two revisions and they will already be selected (if not, select two revisions or the 

project and one revision.) Click Compare. 

6. The Project Compare Editor opens, showing all additions, deletions and changes made between 

the two revisions. 

7. Click Reports and choose a report category. Pick a report to run. 

8. The resulting report will only show what is different between the two Revisions. 
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Managing Revisions and Project Approval 
 

• SI offers an intuitive interface for managing a project’s contract value 

• When a client accepts your proposal 

• You verify which version was accepted and “Promote as Project” if it is 

not the current project 

• Then you set the project as “Approved” 

• All items are marked as approved and price fields are locked 

• Optional and Alternate items are removed from the project 

• SI captures a Revision of the project and shows it as Approved 

• At this point all project changes are managed using Change Orders 

• SI automatically manages Revisions as part of this process 

• Manual revision management is disabled after Project Approval 

• While Revisions and Change Orders complement each other, they are not the 

same thing 

• A Change Order represents pending, approved or rejected changes 

• A Revision captures the state of the entire project at a moment in time  
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ACTIVITY 1.39 - USE PROMOTE AS PROJECT TO SET A REVISION AS THE CURRENT PROJECT FILE 

Note: Since Revisions allow us to modify and present different versions of a project prior to acceptance, 

we need to have the option of choosing a previous Revision and making it the current Project again. 

1. Select your project from the list (single-click.) 

2. Verify the project is checked out to you. If necessary, follow the steps in the previous activity. 

3. Below the list of projects, click on Revisions. 

4. Choose the Revision to promote. 

5. Click Promote as Project. 

6. The Promote Revision dialog box opens, showing two choices. 

a. Choose ‘Backup current project as a new revision’ if you want to save a copy of the current 

project state. 

b. Or choose ‘Do not backup current project as a revision…’ which will NOT SAVE the current 

project state. 

7. Click Promote. 

8. If you chose to backup the current project, the Create Revision dialog box will open. Add Notes as 

necessary and click OK. 
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ACTIVITY 1.40 - MARK PROJECT AS APPROVED 

1. Select your project from the list (single-click.) 

2. Verify the project is checked out to you. If necessary, follow the steps in the previous activities. 

3. If the current version of the Project is to be Approved, simply click the Mark Project as Approved 

button on the Home tab.  Otherwise, use the Promote as Project feature before marking the project 

as approved. 

4. The Mark Project as Approved dialog box opens. 

a. SI sets the Project Status to the first Status with a State of Won.  You can manually change 

this if necessary. 

b. SI automatically creates a Revision of the Project with the note ‘Approved project revision.’  

You can manually change the notes if necessary. 

c. Click Mark as Approved. 

5. A check mark will now be visible in the Approved column within the Project Explorer view. 
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Mark Project As Unapproved 
 

• After a project has been approved, it can be “Unapproved” 

• If a project is marked as unapproved, all Revisions and Change Orders will be 

deleted 

• SI will attempt to set the project status to the first status with an open state 

• Permissions do exist to limit a user’s ability to mark projects as 

approved/unapproved 

 

ACTIVITY 1.41 - MARK PROJECT AS UNAPPROVED 

1. Select your project from the list (single-click.) 

2. Verify the project is checked out to you. If necessary, follow the steps in the previous activities. 

3. Click the Mark Project as Unapproved button on the Home tab. 

4. The Mark Project as Unapproved dialog box opens. 

a. SI resets the Project Status to the first listed Status.  Manually change this if necessary. 

b. Click Mark as Unapproved. 

5. The Approved column check mark will be removed within the Project Explorer view. 

Note: Remember that all previous Revisions and Change Orders WILL BE DELETED!  
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Creating Change Orders 
 

• After a project has been approved, any attempt to make changes requires the 

creation of a Change Order 

• SI prompts the user to select or create a Change Order at this point 

• Change Orders can also be initiated directly from the Change Order tab 

• Change Orders have a name, number, type and status 

• Change Order Type can be: 

• External, or client-facing (change in equipment, change in scope) 

• Internal, for “engineering changes” that do not change the contract 

amount (new model or fulfillment of an allowance) 

• Change Order Status is Pending, Approved or Rejected 

• Change Orders have unique: 

• Scope of Work 

• Price Adjustments 

• Taxes 

• Misc. Items  
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External Change Orders 
 

• When a customer asks for changes, create an external Change Order 

• Additions and deletions change the value of the project 

• Items cannot be deleted directly  

• In a change order, an item can only be “marked for deletion” 

• Items marked for deletion appear with a line through them in the project 

• If the CO is approved, the item will be deleted 

• If the CO is rejected, the item will remain 

• An Undelete function is now available to remove an item marked for deletion 

on a change order 

• Added items appear with a “plus” icon to show they are additions 

• All changes reflect the CO number 
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Change Order Reports 
 

• Change Orders do not require special “change order” reports 

• Standard SI reports are automatically labeled as Change Order by default 

• A report setting allows for the label to be edited 

• When attempting to run a report on an approved project with pending change 

orders, SI requires the user to choose to run the report for: 

• All approved items 

• One of the pending change orders 

• To run a report for an approved change order, open the CO directly from the 

Change Orders tab in the Project Explorer 
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ACTIVITY 1.42 - CREATE AN EXTERNAL CHANGE ORDER 

1. Select your project from the list (single-click.) 

2. Verify the project is checked out to you. If necessary, follow the steps in the previous activities. 

3. Below the list of projects, click on Change Orders. 

4. The New Change Order dialog box opens.  A Change Order Name will be populated.  Change the 

name if necessary. 

5. Choose External for the Change Order Type. 

6. Add Notes to describe the changes.  Click Save. 

7. A Change Order will be added to the list of Change Orders.  The Status will be Pending and the 

Price will be zero dollars ($0.00). 

8. Double-click the Change Order to open the Project and begin making changes. 

9. The default project view will be filtered to the Change Order that you opened.  Use the Change 

Order filter to show items from: 

a. The current Change Order or other Pending Change Orders 

b. The Approved Project 

c. A combination of these 

10. Added items will be displayed with a + next to them and the text will be green. 

11. When deleting items, they will be ‘marked for deletion.’  These items display with an X next to them 

and all the fields display with a strike-through. 

12. Consider making changes to the Scope of Work, Price Adjustments or Taxes. 

13. If the Change Order Filter is set to only show a Change Order, reports will automatically be set to 

run for that CO.  Otherwise SI will prompt the user to select what data the report should use.  
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Internal Change Orders 
 

• Internal Change Orders allow for changes that the customer need not see 

• Possibilities include: 

• minor updates to the BOM for model updates 

• Replacing equipment allowances with actual equipment that can be 

ordered 

• Items that were originally missed in the design but are required 

• SI prompts the user to set added items as Non-billable on internal change 

orders. The goal is to maintain the contract value 

• An item marked for deletion on an internal change order will affect the project 

price once approved 

• It is best not to remove items from an internal change order 

• Instead use the Replace feature which offers: 

• Maintain Installation Prices 

• Keep Accessories 

• Remember, accessory items may have already been installed 
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ACTIVITY 1.43 - CREATE AN INTERNAL CHANGE ORDER 
1. Select your project from the list (single-click.) 

2. Verify the project is checked out to you. If necessary, follow the steps in the previous activities. 

3. Below the list of projects, click on Change Orders. 

4. The New Change Order dialog box opens.  A Change Order Name will be populated.  Change the 

name if necessary. 

5. Choose Internal for the Change Order Type. 

6. Add Notes to describe the changes.  Click Save. 

7. A Change Order will be added to the list of Change Orders.  The Status will be Pending and the 

Price will be zero dollars ($0.00). 

8. Double-click the Change Order to open the Project and begin making changes. 

9. When adding items, SI will prompt the user to mark as Non-Billable. 

10. When deleting items, they will be ‘marked for deletion.’  SI will notify the user that deleted items 

will CHANGE THE PROJECT VALUE when the Internal Change Order is Approved. 
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ACTIVITY 1.44 - RESOLVE A CHANGE ORDER 

1. Change Orders have a Status of Pending until action is taken to resolve them. 

2. When the project stakeholder approves a Change Order, select it from the Change Order list and 

click Mark as Approved. 

Note: External Change Orders should be approved by the customer.  Internal Change Orders should 

be approved by a member of your team (project manager, operations manager, owner, etc.) 

3. The Approve Change Order dialog box opens.  A new Revision will be created.  Approval notes will 

be placed in the Notes field.  Click the Append Change Order Notes link to add those notes to the 

Notes section as well. 

4. Click Mark as Approved. 

5. If the Change Order is rejected, click Mark as Rejected. A read-only version of the CO will be saved. 
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Day 1 Summary - Setup and Sales Training 
 

• Our four sessions included: 

• SI Navigation Overview 

• Control Panel Overview 

• Setup and Configuration 

• Catalog Navigation and Concepts 

• Core Catalog creation (sales focus) 

• Packages and Accessories 

• Catalog Management 

• From Scope and Budget to a D-Tools Project 

• Sales Reports 

• Dashboards for Sales Insights 

• Project Revisions and Change Orders  
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Day 2: Design and Documentation 
 

This training module is divided into four sessions. 

Session 1 

• Documentation Overview and Deliverables 

• Data Related to Documentation 

• Visio Introduction 

• Visio Line Drawings 

Session 2 

• Visio Elevation Drawings and Reports 

Session 3 

• Visio Floor Plans and Installation Reports 

Session 4 

• Visio Schematics and Installation Reports 
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Design and Documentation Overview 
 

• What is Documentation and how can D-Tools help? 

• D-Tools supports a feature-rich integration with Microsoft Visio 

• D-Tools supports two-way communication of data between D-Tools and Visio 

• Build a BOM (project) then drag products to Visio to create a drawing 

• Drag shapes to a drawing to build a BOM 

• Delete products from BOM and they are removed from the Visio drawings 

• Delete products from the Visio drawing and they are removed from the 

D-Tools BOM 
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Documentation Deliverables - Drawings 
 

• D-Tools data can be used to create great design drawings 

• Four types of drawings 

• Line Drawings – used for simple signal flow diagrams (or a sales tool) 

• Elevation – used for wall elevations and equipment racks 

• Plan – indicates equipment locations and wire labels on floor plans  

• Schematics – I/O interconnect drawing maps out details of a functional 

system 
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Documentation Deliverables - Reports 
 

• D-Tools drawings can be used to run reports 

• Equipment Checklists 

• Wire Checklists 

• Wire Connections 

• Equipment Power Requirements 

• Rack Ventilation Requirements 
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Data Related to Documentation 
 

• Images 

• Specifications 

• Dimensions (height, width, depth) 

• Weight 

• Rack Mounted? 

• Rack Units 

• Power and Heat 

• Amps 

• Volts 

• Watts 

• BTU/Hr. 

• Bulk Wire? 

• Wire Start and End Terminals 
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Visio Introduction 
 

• Visio provides a drawing interface that can be connected to data 

• Basic drawing tools are included 

• Line tools 

• Shape tools (ellipse, circle, rectangle, etc.) 

• Text tools 

• Connector tools 

• These basic building blocks can be saved into “Shapes” 

• Shapes are reusable 

• Groups of Shapes are stored in Stencils to help organize them by type 

• SI uses Shapes with special features 

• They store data about products in your project 

• They have their geometry (shape, size, text, color, etc.) controlled by data 
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Visio Introduction (continued) 
 

• Visio makes it easy to create drawings through a drag and drop interface 

• Tools for spacing, aligning, and distributing Shapes are extremely intuitive 

• You don’t need to be a CAD expert to make drawings that look great 

• Visio includes Layers which allow you to organize information on the page 

• Turn Shapes and text on and off 

• Show information on the screen (for reference) but not have it print 

• Add shapes to take advantage of data but hide shapes so the drawing 

looks “clean” 
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Visio Introduction - Shortcuts 
 

• [CTRL] + Mouse Scroll Wheel – Zooms In & Out 

• [SHIFT] + Mouse Scroll Wheel – Pans Left & Right 

• [CTRL] + [SHIFT] + [Left Click] – Zooms In 

• [CTRL] + [SHIFT] + [Left Click & Drag] – Zooms In on a selected area 

• [CTRL] + [SHIFT] + [Right Click] – Zooms Out 

• [CTRL] + [SHIFT] + [Right Click & Drag] – Allows panning on the page 

• [CTRL] + [SHIFT] + [W] – Zooms out to full screen 

• [CTRL] + [1] – Returns to the pointer tool from other tools (try Esc also) 
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Visio Line Drawings 
 

• Great for Sales Documentation 

• Signal Flow or “Block Diagram” 

• Line Drawings are a great way to communicate with non-technical (or less 

technical) stakeholders about complex systems 

• So how do I make a line drawing? 

• Open a project in Visio 

• Select a Line Drawing Page 

• Drag and drop products from SI to Visio 

• Key to success 

• Line Drawings will make use of the Large Image stored with products 

• This improves the appearance of Shapes on Line Drawings 
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ACTIVITY 2.1 - LAUNCH AN SI PROJECT IN VISIO 

1. From the Project Explorer View, select your project file. 

2. On the Home Toolbar click the Visio button and select “New Visio.” 

Note: you can also add a Visio drawing on the right click menu or from Files at the bottom of the 

screen. 

3. This brings up the New Visio Drawing box.  SI supports the latest Visio file format and lets you 

choose between legacy templates (.vst) and the more robust .vstx format. 

 
4. Select the template “D-Tools SI 24x36 Template.” 

5. You can change the file name if you wish.   

6. Click “Populate company logo in title block”.  Click OK 

7. Your drawing file will open in Microsoft Visio. 

8. In the future, you can open your Visio file one of three ways: 

a. From the Visio button on the Home Tab, you can select your Visio files. 

b. From the Right-click Visio menu. 

c. From the Files menu at the bottom of the Project Explorer. 
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ACTIVITY 2.2 - CREATING A LINE DIAGRAM DRAWING 

1. Select the Line diagram page type in your Visio file. 

2. Open the Project Editor to add items to the page. 

3. It is easier to filter the Project Editor before adding items to the page.   

4. Filter for the specific rooms or systems you will be including in the Line Diagram to make it easier 

to find the items and pull them out on the page.   

5. Using Ctrl/Shift + Left Click makes it easier by pulling out multiple items at a time.   

6. Select and drag the items out on the page. 

a. Speakers 

b. Audio/Video sources 

c. Surround Processor/Amplifier or Surround Receiver 

Note: The item seems very small on the page.  This can be corrected by changing the page scale 

so that the line shapes will be larger on the page.  Drag out all shapes before changing the page 

scale; otherwise it will not have the desired effect. 

7. Right Click on the Line Diagram tab at the bottom of your drawing page.  Choose “Page Setup”. 

8. Navigate to the Drawing Scale tab and set your scale to 1.5” = 1 foot.  This will cause the shapes to 

become much larger. 

9. The shapes have probably moved all over the page so move them back on the page if necessary. 

Organizing Items on the Drawing Page 

• Using the Align Shapes tool (Found on the Align tool on the Home Tab) 

• Using the Distribute Shapes tool (Found on the Position tool on the Home Tab) 
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ACTIVITY 2.3 - CONNECTING ITEMS 

It is recommended to use the Line Connector tool, not actual wires from the SI project for this 

purpose.  The Line diagram is not a SI wiring diagram or a schematic drawing. It is simply used as a 

signal flow drawing.  For Schematics; use actual wire shapes (and wire products). 

1. Select the Connector Tool, located on the Home Toolbar in the Tools section. 

2. Once you have selected the Connector Tool you will be able to draw lines on the drawing page. 

3. Anywhere on the drawing page left click (and hold), drag and let go of your mouse button.  A line 

should be drawn on the page. 

4. Use the Line Format tool to change the color of the line to be blue.  By clicking the arrow next the 

button, you can select from many colors. 

5. Now format the line to have an arrow line end on it. 

a. Select the Line Formatting tool from the Home Toolbar on the Shape section. 

b. Drop it down and at the bottom choose “Arrows” 

c. Select one with an arrow pointing to the right 

6. You can also format the line thickness here as well using the Weight sub-menu. 

7. Copy and paste your newly formatted line and format it to be red. 

8. Copy it again and leave it black. 

9. You should now have three lines on the page (blue, red and black). 

10. For our scenario, use blue for Analog Audio, red for Video and black for Speaker signal. 

11. Connect a red and a blue line from the DVD player into the Surround processor. 

12. Connect a red and blue line from the Surround processor to the Amplifier. 

13. Connect the remaining lines on the page.  
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Visio Elevation Drawings and Reports 
 

• Two kinds of dimensionally accurate Elevation Drawings are typical 

• Rack Elevations 

• Wall Elevations 

• Why Rack Elevations? They answer these questions… 

• Will the equipment fit in my rack? (also, is my rack large enough?) 

• In what order should the technician place products in the rack? 

• What are my ventilation and power requirements? 

• Will my rack fit in the available space? Like a cabinet or closet 

• Why Wall Elevations? 

• Will the gear fit in the space I have available? 

• Show where to locate TVs, Speakers, etc. with dimensions 

• Show the customer how the equipment will look in a room 
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ACTIVITY 2.4 - CREATING A RACK ELEVATION DRAWING 

1. Add the package ‘BGR 41 Space Equipment Rack Package’ to your project. 

2. Drag the following parts onto the drawing page from the rack package: 

a. BGR-4127 

b. WB-700-IPV-12 

c. VTP-2 

3. Place the rack and other parts in the middle of the page. 

4. Notice, the rack looks small compared to the size of the page?  This is due to the page scale. 

5. Let’s change the page scale so the rack appears larger on the page. 

6. Right Click on the Elevation tab and select “Page Setup”.   

7. Go to the Drawing Scale tab and select a scale of 3” = 1’0”. 

8. Move the rack and parts to the left side of the page. 

9. Now drag other equipment onto the page from your project. Items like: 

a. Receiver 

b. Blu-Ray (with shelf) 

c. Cable Box (with shelf) 

10. Attach the rack shelf shape to the rack.  You will know it is connected when a red box appears in 

the upper left hand corner. 

11. Now attach the Blu-Ray player on top of the shelf. It will attach in the lower left hand corner.  You 

will know it is attached when the red box appears. (Continued on next page.) 
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ACTIVITY 2.4 CONTINUED 

12. After you let go of your mouse, the Blu-Ray player may disappear behind the shelf shape.  

13. The reason this happens is due to the layering effect on the D-Tools drawing page.  Items dragged 

on the page first appear further back on the page.     

14. The Blu-Ray player needs to be “brought forward” so that it appears on top of the shelf. 

15. Slowly click two times on the shelf shape.  The first click will select the shelf, the second click should 

select the Blu-Ray player behind it. 

16. Now Right-click and select Bring to Front. 

17. The Blu-Ray player will now be moved in front of the shelf. 

Tip: You can avoid this from happening in the future by dragging the RSH shape out onto the page 

first, and then the piece of equipment. 

18. Complete the rack layout for the remaining components. 

19. In Your Stencil Tree, find the Custom category and open the DT Annotations stencil.  Find the shape 

‘Rack Unit Tape Measure’ – you can attach this shape and it will count the rack units on the side of 

the rack! 
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ACTIVITY 2.5 - CREATING A RACK SIDE VIEW 

The SI Elevation page has tools to create rack side views.  The rack side view allows us to see the 

depth of equipment in a rack.  The side view shapes use Height and Depth from the product data to 

determine the size of the shape. 

1. Select the rack and all the shapes using Ctrl + Left-click (or drag a window around the items.) 

2. Avoid selecting the shelf shapes (holding Ctrl key you can ‘deselect’ items.) 

3. Select D-Tools → Shape → Generate Side View. 

4. The side view shape of the rack and all the components will be generated.   

5. Notice that the side view shapes do not automatically align themselves with the parent 

component’s rack position so this will need to be completed. It is quick to use the align tools. 

6. First, to align all the shapes with the front face of the rack (left side) 

a. Select the rack shape. 

b. Hold down the Ctrl key and select the remaining side view shapes. 

c. From the Home Tab, in the Arrange Section, click the Position tool and select the Align Left 

option (this will vertically-align the shapes on the left side of the rack – using the first 

selected shape, the rack, as the basis for the alignment). 

7. To align the side view shapes with the parent shapes you will want to follow these steps: 

a. Select the parent shape in the main rack. Hold the Ctrl key and select the side view shape. 

b. From the Home Tab, in the Arrange Section, click the Position tool and select the Align 

Middle option (this will horizontally align the shapes on the middle – using the first selected 

shape as the basis for the alignment).  
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ACTIVITY 2.6 - USING CABINET TOOLS FOR A CABINET DRAWING 

Cabinet Tools is a utility for creating dimensionally accurate cabinet drawings.  These drawings are not 

linked to D-Tools; they are just Visio shapes designed to create dimensioned cabinet layouts. 

Insert a New Page for Cabinet Drawing 

1. Insert a new page in the drawing set by clicking Insert → New Page. 

2. When prompted for the page type, select Elevation. 

3. Name the new page ‘Cabinet Drawing’ and click OK. 

Layout Cabinet Drawing 

1. From the D-Tools SI Shapes Menu, under Custom, find the stencil called ‘Cabinet Tools.’ 

2. Right-click on it and choose Open Stencil. 

3. This opens the stencil in the shapes window so the shapes may be viewed. 

4. Drag the Cabinet Bottom shape out on to the page three times. 

5. Right-click on the middle shape and choose Adjust Height, Width and Kick. 

6. Change the Width to be 60”. 

7. Right-click on the left most cabinet frame shape and choose Adjust Height, Width and Kick. 

8. Change the height to be 72”. 

9. Do the same for the right most cabinet shape. 

10. Line the three cabinet shapes up so that they are 

grouped together like this: 

(Continued on next page.) 
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ACTIVITY 2.6 CONTINUED 
11. Right click on one of the cabinet shapes and select Show Solid Door.  This makes a solid door 

appear over the front of the cabinet. 

12. Now Right Click on the same shape and click Choose Wood Fill. 

13. This brings up the Format Shape dialog box.  Select Pattern Fill then choose the Pattern drop 

down list and select a wood fill for your cabinet. These options may vary slightly depending on the 

version of Visio you are using. 

14. Repeat this step for the remaining cabinet pieces. 

15. From the DT Annotations stencil, drag out a shape called “Universal Dimension Shape Horiz.” 

16. Attach it to the connection points on top of one of the cabinet shapes like this (see below).  You 

can dimension your entire cabinet drawing to show all elements of its size. 

  
17. Please feel free to try out the other stencils available with Cabinet Tools to draw your own 

creative cabinet drawings! 
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Visio Floor Plans 
 

• Floor Plan Drawings serve two purposes 

• Prewire Documentation 

• Specify Device Locations 

• Plan View Shapes 

• New SI Plan Shapes – highly configurable and enable creation of 

customized iterations for different products/categories 

• Icon Shapes – resizable, used primarily for Trim items (keypads, 

speakers, wireless access points, etc.) 

• Scale Plan Shapes – Not resizable, dimensionally accurate. Ideal for 

showing rack locations and other devices where placement details are 

important 

• Wire Shape – “Bulk Wire” is the default wire shape for the plan view but 

other wire shapes are also available  
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ACTIVITY 2.7 - CONFIGURING & SAVING SHAPE DATA: SPEAKER SHAPE 

The new SI plan view shapes allow the user to configure the shape, shape color and other information 

and save these settings for a specific product or a specific Category/Subcategory. 

1. To make this activity run as smooth as possible, start by cloning a speaker product in the Catalog. 

Use your initials in the name to make sure it is unique. Now use this unique speaker. 

2. Drag a speaker onto the plan view page from the Project Editor. 

3. On the Visio toolbar Select the VIEW tab. 

4. From the Task Panes button select Shape Data (with shape data window open, any shape you 

select, you will be able to view the configurable options for that shape.) 

5. Typically, you will have the following configurable options: 

a. Shape Type 

b. Mount Type 

c. Fill Color 

 

d. Smart Rotate Text 

e. Show Component ID 

f. Show Note 

 

g. Note Text 

h. Icon Size 

i. Icon Text

6. Change the settings for the speaker shape as you see fit. 

7. Once your changes are made, right-click → D-Tools → Shape → Assign Product & Category. 

8. This brings up the Shape Assignment window which allows you to assign the specific shape 

configuration (when this item is used on the plan view page type.) 

9. You can assign the shape settings for: 

a. Specific Product. 

b. All items in a specific category. 

c. All items with a specific subcategory. 
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ACTIVITY 2.8 - CONFIGURING & SAVING SHAPE DATA: WIRE SHAPE 

1. To make this activity run as smooth as possible, start by cloning a bulk wire product in the 

Catalog. Use your initials in the name to make sure it is unique. Now use this unique wire. 

2. Drag your cable onto the plan view page from the Project Editor. 

3. With Wire Shapes, you have a more limited range of shape data configuration available: 

a. Show Text 

b. Line Color 

c. Line Pattern 

d. Line Weight 

e. Arrow Style 

4. Change the settings for the wire shape as you see fit. 

5. Once your changes are made, right-click → D-Tools → Shape → Assign Product & Category. 

6. You can assign the shape settings for: 

a. Specific Product. 

b. All items in a specific category. 

c. All items with a specific subcategory. 

7. This allows you to configure the specific colors you want to use for specific types of wire!  Your 

wiring drawings will always comply (automatically) with a designated color scheme for wiring! 

  



D-Tools System Integrator 
 

 

 

 

 

 
© 2016-2018 D-Tools Inc. | Professional Services Group  Training Guide - 79 

 

Visio Floor Plans – Right-Click Commands 
 

• Right-click Commands are available in many Plan shapes 

• Plan Icons 

• Show Component ID: Choose to display the ID or not 
• Show Note: Any note text configured in the shape data window for the 

shape will either show/hide 
• Smart Rotate Text: Allows text to rotate along with the shape and remain 

readable 
• Color: Select fill color for the icon 

• Wire Shapes 

• Show Text: Shows the Text (Manufacturer, Model, Component ID and 
Type) 

• Merge Text Blocks: Merges the Component ID field with the other fields.  
Unmerged shows Component ID separately 

• Text Display: Gives you the choice individually of whether to show the 
following fields 

• Component ID, Manufacturer, Model, Type (Subcategory)  
• Line Formatting: Line Color, Line Weight, Line Style and Arrow Style  
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Visio Floor Plans – Working with Floor Plan Drawings 
 

• Several Methods for inserting a floor plan in Visio 

• D-Tools Insert PDF Background Utility 

• Great visual results, flexibility and can be to scale 
• Limited by the PDF source 

• Insert an AutoCAD DWG file 

• Great visual results and flexibility, and can be to scale 
• Works best in Visio 2019 and the latest Office 365 versions 

• In earlier versions a Visio bug can damage the CAD file 
forcing the user to insert again 

• May require AutoCAD software and CAD knowledge 
• Look at DWG TrueView as a free option for saving AutoCAD .DWG 

files to different versions 
• Insert a JPEG or Bitmap 

• Easy to use but limited fidelity without large image files (think 
bloated Visio file) 

• No scale or difficult to scale 
• PDF Snapshot tool is an option 
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ACTIVITY 2.9 - INSERT AUTOCAD DRAWING 
CAD files inserted into Visio need to be prepared in a specific format to be used effectively. There is a 

series of steps for file preparation, that will make CAD file insertion seamless. 

Quick Tips on CAD Prep 

There are a few basic rules for CAD files (the most common things that cause issues with importing) 

• X-Refs:  The biggest culprit is X-refs or external references.  Visio will not accept a CAD file 

that has X-refs attached.  X-refs must be bound to the main file or removed.   

• Layer Settings:  Make sure all layer properties are set to “By Layer”: This allows for CAD 

drawing layer visibility and colors to be manipulated inside Visio. 

• File Version: Older versions of CAD files tend to import best.  Save the file as R14 or 2000 

DWG. 

• CAD prep Tool: If you don’t own AutoCAD, you can sue a free software called Draft Sight to 

open the CAD files and manipulate them as needed for them to be imported to Visio. 

1. From the Insert Menu select “CAD Drawing” 

2. Now browse to the CAD file on your 

computer and select “Open.” 

3. This brings up the CAD Drawing Properties 

window.   

(Continued on next page.) 
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ACTIVITY 2.9 CONTINUED 
4. Set Scale to Pre-defined scale = Page Scale. (see picture on page 61.) 

5. Use the Apply button to test (allows you to see the size of the CAD file on the page.) 

6. Verify that CAD Drawing Units is set to Inches, not Feet. 

7. Unlock Size & Position. 

8. Unlock Against Deletion. 

9. Leave View Extents checked. 

10. Layers Tab: this is where you can turn on/off layers and set the color properties for the layers. 

11. Each Layer has a Name, a visibility status, a color and line weight.   

12. Click OK to insert CAD File. 

13. The CAD file should now appear on your drawing. 
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ACTIVITY 2.10 - INSERT A FLOOR PLAN USING OTHER FORMATS 

Sometimes a CAD file is not available. An image file gives us another option. These options are generally 

not to scale but can still provide good results. 

JPEG or Bitmap Insertion 

1. From the Insert menu, select Picture. 

2. Browse to and select the sample jpeg provided with the course. 

3. Resize, reposition and crop as necessary. 

 

PDF Snapshot Insertion 

1. Open the sample PDF floor plan provided with the course in Adobe Reader. 

2. From the Edit Menu select Take a Snapshot or Snapshot Tool. 

3. This will take a copy of the floor plan. 

4. Paste the image into Visio. 

5. Resize, reposition and crop as necessary. 

Tip: The closer you zoom in to the floor pan in Acrobat, the more detail that will show after pasting in 

Visio. Keep in mind that this also means a larger file. 
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ACTIVITY 2.11 - USING INSERT PDF BACKGROUND (CUSTOM INSERT FROM SI) 

There are several ways to insert CAD drawings into an SI project. Each has pluses and minuses. The PDF 

file format has emerged as a standard for sharing information. The Insert PDF Background tools help 

you take advantage of this great format. 

1. Right-click on a drawing page, select D-Tools → Insert PDF Background. 

2. The Insert PDF Background Instructions page opens. Read these steps and follow them for good 

results. 

3. Click Continue and then select a PDF file. 

4. The PDF file will be loaded into a preview window that appears on the screen. 

5. Make choices about which pages you would like to insert from the PDF, page size, scale, etc. 

6. Click Insert. 
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ACTIVITY 2.12 - OPTIONAL: CREATING A BACKGROUND PAGE FOR FLOOR PLAN 

If you have a lot of items to document on your plan view, sometimes it’s beneficial to separate the 

items out onto several pages.  Rather than importing the Cad files multiple times (which can create a 

large file size) you can use a background title page to store the cad so it can be referenced on 

multiple pages easily. 

1. From the Insert menu, click New Page → Background Page. 

2. This brings up the Page Setup dialog box. Set these values: 

a. Page Type = Background (pre-selected.) 

b. Add a Page Name (i.e.: Floor plan.) 

c. Background = Background Title Page. 

d. Measurement Units = Inches. 

e. Select Drawing Scale Tab and set Drawing Scale to 1/4” = 1’0”. 

3. Click OK. 

4. Now you are prompted to select a Page Type.  Choose Plan. 

5. Insert CAD drawing on this page using one of the techniques you learned. 

Associate Background Page with Plan View 

This step allows us to modify the plan view page to use our newly created floor plan 

background page. 

1. Select the Plan View page tab. 

2. Go to the File menu and choose Page Setup. 

3. Select the Page Properties tab. 

4. Select your floor plan background page as the background and click OK. 
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Visio Floor Plans and Installation Reports 
 

• Use of Floor Plan Drawings to run reports 
• Devices located on a page can be used as the source of report data 
• This includes wire connections  
• Typical Reports: 

• Equipment Checklist 
• Wire checklist 

 

ACTIVITY 2.13 - WIRE CHECKLIST REPORT 

The Wire Checklist report is run for prewire connections.  It details From-To locations at the prewire 

connection level. It will show the Head End a wire is coming from as well as the Location and device to 

which it is attached. Also,  shown: the wire Mfr-Model, Wire Number and Type. 

1. Navigate to the Reports tab on the Project Editor. 

2. On the Options section select the filtering option Current Drawing Page. 

3. From the Installation Reports list, select the Wire Checklist report.  This report can be run with 

wires grouped by Head End, Location or Wire Number. 

4. Select by Location (this groups the wires in the report by Location.) 

5. Take notice that only the wires we used on this page are showing up in the report. 

Note: Standard filters could be used to specify criteria for this installation report. 



D-Tools System Integrator 
 

 

 

 

 

 
© 2016-2018 D-Tools Inc. | Professional Services Group  Training Guide - 87 

ACTIVITY 2.14 - CHECKLIST REPORT (PRODUCT) 

The Checklist report gives you a field checklist for installing various items in the project. 

1. Navigate to the Reports tab in the Project Editor. 

2. On the Options section select the filtering option Current Drawing Page. 

3. From the Management Reports list, select the Checklist report. 

4. Select By Location as the grouping option. 
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Visio Schematics 
 

• Schematics document point to point connectivity between devices 

• Input / Output data is used to generate the shapes 

• Wire shapes are used to make the connections between the I/Os 

• Some Schematic Layout Basics 

• Far Left: Sources 

• Middle Left: Switching 

• Middle Right: Amplification 

• Far Right: Outputs (speakers, keypads, displays, etc.) 

• What about power and control? 

• Above or below? 
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Visio Schematics – Right-Click Options 
 

• Show Connected Terminals – Displays only the Connected Terminals on the 
schematic block 

• Show Labels - Allows you to show/hide the Labels on the Schematic block 

• Show Signals - Allows you to show/hide the Signals on the Schematic block 

• Show Terminals - Allows you to show/hide the Terminals on the Schematic 
block 

• Show Terminals Top to Bottom - Displays the shape’s I/O Connections from 
Top to Bottom 

• This option can be set as default in the global settings for projects, this right 
click option allows for overriding the default setting 

• Show Location - Allows for the location of the product to be shown on the 
schematic shape.  Handy for like items in many rooms (speakers, keypads, 
etc.) 

• Show Leader Lines – Shows a leader line between the shape and Component 
ID if this label is dragged from the shape  

• Show Center Line: Allows hiding of the center line on schematic shape 
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ACTIVITY 2.15 - LAYOUT YOUR SCHEMATIC SHAPES 

Moving and aligning the shapes manually into their respective “quadrants” on the page. 

5. Drag several speakers on to the drawing page from your project (add if necessary.) 

6. Place one of the speakers at the top of the page and one of the speakers at the bottom of the 

page on the right side of the screen. 

7. Left-click and drag a large selection box from the top to the bottom of the page.  (It is important 

to do this top to bottom.) 

8. All the speakers should be selected. 

9. Use the Align on Center tool (located on the Position tool) to align all the speakers on center with 

the top speaker. 

10. Then you will want to use the Distribute Vertical Spacing tool (located on the Position → Space 

Shapes toolbar) to evenly space all the speakers along the right side of the page. 

11. This is the process you would continue to follow for manual layout of your shapes. 
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ACTIVITY 2.16 - MAKING WIRE CONNECTIONS 

When making connections on schematic drawings, work systematically, left to right across the page.  

Also, make most connections before trying to clean up the wire routing and crossing. 

1. Select a product on the page, Right-click → D-Tools → Find in Project Explorer. 

2. Now that you have found the item, drag the item’s wire accessories onto the page. 

Note: It is easier when you know the intended purpose of wires in your project editor! 

3. Connect the wires to the output terminals (right side) on the device. 

4. Connect the same wires to the appropriate downstream device (to the right). 

5. Repeat this process for the remaining devices. 
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Visio Schematics – Off-Page References 
 

• Off-Page References allow products on different pages to be connected 

• Examples 

• Network infrastructure with connections to audio, video, and control 

equipment on other schematics 

• A central A/V switcher with connections across a large building. Each 

destination might be on a separate page 

• The Off-Page Reference (OPR) shape is connected to one end of a wire that is 

connected to a device. The OPR shape references the page and device where 

the wire goes 

• The page where the second device is located gets a copy of the wire and 

another OPR shape pointing back to the first device 
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ACTIVITY 2.17 - INSERT AN OFF-PAGE REFERENCE (OPR) SHAPE 

An effective demonstration of using an Off-Page Reference requires equipment on two different 

schematic pages. To begin, insert a second schematic page. 

1. From the Insert menu, click New Page → Blank Page. 

2. When prompted, select Schematic for the page type. 

3. Make note of the name of the new page. 

4. Add a device from your project onto the new page. 

5. Return to the original schematic page. 

6. Connect a wire to a device on this page. 

7. Right-click on the wire. Select D-Tools → Wire → Create Off-Page Reference. 

8. On the Create Off-Page Reference dialog box, 

select the Existing Page radio button and 

select your new schematic page from the 

drop-down list. Click Create. 

9. The selected wire will now have an OPR 

shape attached. 

10. Switch to the second schematic page. A second copy of the original wire with an OPR shape 

attached will be in the middle of the page. 

11. Connect the open end of the wire to the device you added to this page earlier. 

12. The OPR shape references the page, device and connection on the other end of the wire. Ctrl-

Click the OPR shape to ‘jump’ the wire on the original schematic page. Now, each OPR references 

the opposite page.  
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Visio Schematics and Installation Reports 
 

• Wire Connection Reports 

• Show To/From device connections with locations for each wire 

• Can also identify termination types 

• Wire Termination Count 

• Provides a count of terminations needed, if wires have terminations 

defined 

• Wire Labels 

• Provide matching wire labels to go with wire checklists 

• Brother Wire Labels – send label data directly to a Brother labeler 

• Laser Printer Wire Labels – use a laser label template to make wire wraps 

• Export Wire Connections – use wire connection data however you choose 

• Excel template or direct to USB label printer 
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ACTIVITY 2.18 - WIRE CONNECTIONS REPORT 

The Wire Connections report is run for terminated connections made on schematics.  It provides 

connection details from the output device to the input device, wire Mfr-Model, Wire Number and 

Type (Subcategory.) 

1. Navigate to the Reports tab on the Project Editor. 

2. On the Options section select the filtering option Current Drawing Page. 

3. From the Installation Reports list, select the Wire Connections report.  This report can be run with 

wires grouped by Manufacturer, then Wire Number or just Wire Number. 

4. Select by Wire Number (this sorts the connections by Wire Number). 

5. Take note that only the wires used on this page are showing up in the report. 

Note: Standard filters could be used to specify criteria for this installation report. 
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Day 2 Summary - Design and Documentation Training 
 

• Our four sessions included: 

• Documentation Overview and Related Data 

• Documentation Deliverables – Drawings and Reports 

• Visio Introduction 

• Visio Line Drawings 

• Visio Elevation Drawings and Reports 

• Visio Floor Plans and Installation Reports 

• Visio Schematics and Installation Reports 
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Day 3: Operations 
 

This training module is divided into three sessions. 

Session 1 

• Operations Overview 

• Data related to Operations 

• Purchase Order Requests/Tracking 

• Purchase Orders 

Session 2 

• Scheduling 

• Tasks 

• Service Orders 

Session 3 

• Mobile Install 

• Resource Hours 
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Operations Overview 
 

• How can D-Tools help manage projects once sold? 

• Track overall project status (Project Statuses) 

• Issue Purchase Order Requests 

• Issue Purchase Orders – By Vendor 

• Track and Receive Orders 

• Track product/material acquisition for my projects 

• Scheduling 

• Tasks (Contract project work) 

• Service Orders 

• Service existing projects 

• Service new customers 

• Installation tracking from the project 

• Mobile Install – Mobile app for managing tasking and resources 

• Resource Hours – How and where is my team being utilized? 
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Data Related to Operations 
 

• Project Status (Milestones) 

• Vendors 

• Vendor Details 

• Contacts 

• Purchasing 

• Preferred Vendor 

• Order Unit of Measure 

• PO Number 

• Purchase Status 

• Expected Delivery Date 

• Received Date 

• Installation 

• Serial Number 

• IP Address 

• Install Status 

• Install Date 

• Install Notes 
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Purchase Order Requests/Tracking 
 

• A Purchase Order Request (POR) is just a report we run from a project 

• We can filter products in different ways: 

• Order Status 

• Phase 

• Location 

• Vendor/Manufacturer 

• Using these filters helps us to decide what items to request on the POR 

• PORs are not tracked in the software 

• A custom field could be used for this purpose 

• Or setting the Order Status and Number 



D-Tools System Integrator 
 

 

 

 

 

 
© 2016-2018 D-Tools Inc. | Professional Services Group  Training Guide - 101 

ACTIVITY 3.1 - FILTER ITEMS BEFORE RUNNING A POR REPORT 

1. From a project, on the Home tab, select Quick Filter. Near the bottom of the window is the Orders 

icon. Select it and you can filter on orders for the project. 

2. If no orders exist, move on to filter by Phase (6th icon from the top). Choose a phase and the view 

will be filtered to your selection. 

Note: Try other options like Manufacturer or Vendor.  More than one filter can be applied at the same 

time. 

ACTIVITY 3.2 - RUN A POR REPORT ON FILTERED ITEMS 

1. Click on the Reports tab. 

2. In the Include Options section, select Filtered Items. 

3. In the Reports section select Management. 

4. When the Management Reports window opens, double-click on Purchase Order Request. 

5. The report will run and open.  

6. You can export to PDF or Email a copy directly to your purchasing agent. 
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Purchase Orders 
 

• Purchase Orders are Issued by Vendor 

• All products in the Catalog need a vendor assigned 

• They can contain items for single/multiple projects and/or items for stock 

• PO’s can be sent via email or published to the Vendor Portal 

• Tracking the receipt of multiple shipments for a single PO is supported 

• PO information is pushed back to the project: 

• PO Number 

• Date Issued 

• Status 

• Date Received 
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ACTIVITY 3.3 - CREATE AND ISSUE A PURCHASE ORDER 

1. Navigate to the Project Explorer. Select your working project. 

2. In the project detail section, below the list of projects, click on Purchase Orders then click New.  

3. In the New Purchase Order window, click on Products. 

4. Next click Add from Project → Products Summarized. 

5. The Select Project dialog box will open and your project will be selected. Click Select. 

6. A list of products available in the project will open. Choose a Vendor on the left. This will filter the 

list to the selected Vendor. 

7. Use a Ctrl-click or Shift-click to select products. Click Add and Close. 

8. At the bottom of the New Purchase Order window, click in the Tax drop down. Select the empty 

line. This will remove tax from the PO. 

9. Now click on the General button and, in that section, select the appropriate Vendor. 

10. Set the Status to Issued. 

11. Set a Requested Delivery Date and Shipment Preference. 

12. Click Save and Close. Now you will be viewing the Project Explorer again. 

13. Click Start → Purchase Orders → Manage Purchase Orders. 

14. Your new PO should be at or near the top of the list. Select it. 

15. Click Reports. Then under Standard Reports, double-click Purchase Order. This is your PO. 

16. Open your project and follow the prompts to update Item Order Fields. 

17. To view the updated ordering information, click on Layouts → Order. 

The Order layout will focus on ordering information.  
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ACTIVITY 3.4 - RECEIVE ITEMS FROM A PURCHASE ORDER 

Issuing purchase orders is half of the purchasing story. Next, items can be received and tracked. 

1. From the Purchase Order Explorer, select the PO you created earlier. 

2. Below the list of PO’s you will see a section labeled Purchase Order Receives. Click New. 

3. A new Purchase Order Receive opens, showing the items ordered. Columns include Ordered, 

Received and Qty. to Receive. Click on an item’s row under the Qty. to Receive column and type a 

quantity to receive. Do this for a few items but do not ‘receive’ all quantities of all items. 

 
4. Click Save and Close. Your PO status should now be listed as Partially Received. 

5. Repeat steps 1 – 4 but this time notice the Received column shows the quantities received in the 

first Receive. Now receive the remaining items. When complete, your PO status should show as 

Received. 

6. Return to your project and click the Tools tab. Find Update From → 

Purchase Orders and click it. This will allow you to again update Item Order 

Fields showing items have now been received. 

Tip: PO receiving can also be shared with QuickBooks. After receiving a PO, click ‘Create QuickBooks Item 

Receipt from the Purchase Order Receives menu. 
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Scheduling - Tasks 
 

• Tasks allow you to schedule work to be completed for a project 

• Tasks include products with associated labor 

• The sum of the labor associated with these tasks creates a time budget 

• One or more resources may be assigned to a task 

• A task is scheduled on the calendar 

• The total number of hours and the number of resources assigned can be used 

to determine a duration for the task 

• Tasks can be issued as reports, sent via email, or published to Mobile Install 
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ACTIVITY 3.5 - CREATE AND SCHEDULE A TASK 

1. Click Start → Schedule → Manage Tasks. The Task Explorer opens. 

2. On the Home tab, click New. The Select Project window opens. 

3. Select your Client and then your Project. Click Select. The New Task window opens. 

4. Every Task needs a name. Type something like ‘[Your Initials] – Rough-in’ or another descriptive 

name that will look unique in the list of Tasks. 

5. Type a description in the Description field. Keep it short. 

6. On the Navigate section at the top of the window, click Items. 

7. Click Add Products. The Add Products window opens. 

8. Consider using Quick Filters to select a specific phase, location, or another filter. Then select items 

from the list. Click Add and Close. The items will be added to the Task. 

9. Next click the Resources button. Click Assign. The Assign Resources window opens. 

10. Choose a Resource from the list and click Assign. Notice the Estimated Hours for the Resource is 

set to 1.000. This is a default value. 

11. On the bottom-left of the window select Assign estimated hours based on total labor hours. Click 

Yes when prompted. The Estimated Hours should be updated. 

12. Click General, then click on the Start Date. Pick a date on the calendar. 

13. Next click Compute End. The Compute End Date dialog box will open. 

14. Select the Estimated Resource Hours radio button. Click OK. 

15. Click Save and Close. Choose No when prompted to publish the task to Mobile Install. This task will 

be completed later. (Continued on next page.)  
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ACTIVITY 3.5 CONTINUED 
16. Now your Task is created and scheduled but the Resource has not been notified. 

Note: Sometimes it is best to wait to send out Tasks in case the schedule moves around. 

Select your Task from the list in the Task Explorer. Click Reports. Then under Standard Reports, 

double-click Task Detail. This is your Task. You can save the report as a PDF and email to the 

Resource. 

17. If you use Outlook, Outlook.com or Google Calendar, you can 

click Send To and then pick one of those choices. Follow the 

prompts to send your Task. 

Note: While a PDF Task Detail report will be added when working 

with Outlook, no report will be attached for Google or Outlook.com 

calendars. 

18. Back in the Task Explorer, click Calendar. This will open the Calendar view and allow you to view 

Tasks on a traditional calendar. 

Note: The Merge Calendar option makes viewing multiple Tasks easier. 
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Scheduling – Service Orders 
 

• Service Orders work almost identically to Tasks 

• Tasks require a project, service orders do not 

• Service Orders only require a Client 

• Products and Labor can be added directly from the Catalog 

• Site Labor Settings can define a labor rate to add labor in the field 

 

ACTIVITY 3.6 - CREATE AND SCHEDULE A SERVICE ORDER 

Creating a Service Order is like creating a Task. Instead of choosing a project, you only need a Client. 

However, if you are performing service on an existing SI project, pick the project as well. 

1. Click Start → Schedule → Manage Service Orders. The Service Order Explorer opens. 

2. On the Home tab, click New. The New Service Order window opens. 

3. Select your Client (and then your Project.) 

4. Provide a name. Type something like ‘[Your Initials] – Troubleshoot TV’ or another descriptive name 

that will look unique in the list of Service Orders. 

5. Type a description in the Description field. Keep it short. 

6. On the Navigate section at the top of the window, click Labor. 

7. Click Add. The Add Labor window opens. (Continued on next page.) 
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ACTIVITY 3.6 CONTINUED 
8. Scroll down and select Standard Service Call in the list. Click Add and Close. The labor item will be 

added to the Service Order. 

9. Next click the Resources button. Click Assign. The Assign Resources window opens. 

10. Choose a Resource from the list and click Assign. Notice the Estimated Hours for the Resource is 

set to 1.000. This is a default value. 

11. In this case, you may want to simply type in a number of hours based on your estimate of the time 

needed to work through the Service Order. 

12. Click General, then click on the Start Date. Pick a date on the calendar. 

13. Next click Compute End. The Compute End Date dialog box will open. 

14. Select the Estimated Resource Hours radio button. Click OK. 

15. Click Save and Close. Choose No when prompted to publish the task to Mobile Install.  

16. Now your Service Order is scheduled but the Resource has not been notified. Select your Service 

Order from the list in the Service Order Explorer. Click Reports. Then under Standard Reports, 

double-click Service Order Detail. This is your Service Order. You can save the report as a PDF and 

email to the Resource. 

17. If you use Outlook, Outlook.com or Google Calendar, you can 

click Send To and then pick one of those choices. Follow the 

prompts to send your Service Order. 

Note: While a PDF Service Order Detail report will be added when 

working with Outlook, no report will be attached for Google or 

Outlook.com calendars. 

18. Back in the Service Order Explorer, click Calendar. This will open the Calendar view and allow you 

to view Service Orders on a traditional calendar.  
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Mobile Install 
 

• Mobile Install is a web app that is linked to Tasks and Service Orders 

• Field resources can interact with Tasks and Service Orders through the Mobile 

Install interface 

• Mobile Install allows installers to update the status of Tasks and Service 

Orders, providing near real time feedback to SI  

• Mobile Install offers a calendar view, a task list view, and shows all details of 

Tasks and Service Orders 

• It is compatible with any web-enabled device and runs in the web browser 
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Resources Hours 
 

• The Resource Hours tools allow project managers to understand resource 

utilization 

• Where was an installer on a given day or week? 

• How many hours has a resource worked on a specific job this month? 

• How many hours have been tagged to Service Orders this quarter? 
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ACTIVITY 3.7 - RESOURCE HOURS REPORTING 

1. Click Start → Schedule → Resource Hours. The Resource Hours window opens. 

2. On the upper-left select the Period drop down and choose This Week or This Month. The view will 

filter to the time period. 

3. Down the left side is your list of Resources and Projects. You can look at all Resources and Projects 

during this period or pick specific Resources and Projects. 

4. Select a Resource shown in the list. Any Tasks or Service Orders assigned to the Resource during 

the period will be listed below. (Continued on next page.) 

5. By selecting a Task or Service Order shown, you can click Update Hours which allows you to enter 

Estimate and/or Actual Hours as well as adjust the Cost/Hr. This works well when you are issuing 

Tasks and Service Orders as 

reports and not using Mobile 

Install. When a Task is 

completed you can enter data 

here to reflect the time used. 

Enter a number for Actual Hours and select Update. 

6. The Actual Hours will be updated in the Task or Service Order as well as the Resource Hours above.  

7. Click Export. You can export a Summary or Detail report. Try both. 
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Day 3 Summary - Operations Training 
 

• Our three sessions included: 

• Operations Overview 

• Data Related to Operations 

• Purchase Order Requests/Tracking 

• Purchase Orders 

• Scheduling 

• Mobile Install 

• Managing Resources 
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Appendix A: 
Multiple Currency Support 

 
This content is developed as an introduction to using multiple currencies in SI. 

Topics 

• Currency Overview 

• Enabling Multiple Currencies 

• Additional Currencies 

• Apply a Default Currency to a Client/Vendor 

• Apply a Currency to a Project 

• Change Currencies in a Service Order 

• Manage Currencies in a Purchase Order  
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 Currency Overview 
 

• SI provides options for managing currencies in: 

• Projects 

• Service Orders 

• Purchase Orders 

• Multiple Currencies can be defined 

• Conversion Rate Lookup is included 

• Manual Editing of the Rate is an option 

• Project Reports also include a Foreign Currency Option 

• Report in currencies other than your default 

• Without editing the currency/price values in the project data 

• Buy and Sell in any Currency 
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 Enabling Multiple Currencies 
 

• Currency Settings allow SI users to manage multiple currencies beyond the 

company’s default currency 

• There are user permissions related to Currency Settings 

• When you enable multiple currencies, you will be prompted to set your default 

currency 

• Once enabled, Multiple Currencies cannot be turned off 

• After this, additional currencies can be added 

• SI will calculate conversion rates for your new currencies 

• After currencies are defined, we can apply them to Projects, Service Orders and 

Purchase Orders 
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ACTIVITY A.1 - ENABLE MULTIPLE CURRENCIES 

1. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

2. In the Currency section, click Currency Settings. This opens the Currency Settings window. 

3. Check the box next to Enable Multiple Currencies. 

Note: This cannot be disabled once saved. 

4. Set your default currency and culture. 

Note: This cannot be changed once set. 

5. Verify your settings are correct before clicking Save to save your settings and close the window. 
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 Additional Currencies 
 

• Use the currency lookup to find the needed currency 

• Update Rates with the online conversion rate lookup tool 

• Allow Rate Editing option allows for manually editing the rate 

 

ACTIVITY A.2 - ADD CURRENCIES 

1. Starting from the Control Panel, Currencies section, double-click Currencies. 

2. To create new currencies, click New. In the New Currency window, choose a currency from the 

dropdown menu. 

3. The conversion rate will automatically populate. 

4. Choose the Culture to represent the currency. 

5. Click Save. 
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 Apply a Default Currency to a Client or Vendor 
 

• Clients/Vendors can have their own default currency 

• This allows new Projects, Service Orders and Purchase Orders to inherit the 

default 

• Simply open a client/vendor record and set the default currency 

 

ACTIVITY A.3 - ASSIGN A CURRENCY TO A CLIENT 

1. Starting from the SI application, click People → Clients. The Client Explorer opens. 

2. Select a Client and click Edit. 

3. At the bottom of the General section, choose a currency from the list. 

4. Click Save and Close. 

 

ACTIVITY A.4 - ASSIGN A CURRENCY TO A VENDOR 

1. Starting from the SI application, click People → Vendors. The Vendor Explorer opens. 

2. Select a Vendor and click Edit. 

3. At the bottom of the General section, choose a currency from the list. 

4. Click Save and Close.  
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 Apply a Currency to a Project 
 

• In the Project Wizard, on Step 1, choose: 

• Use your default currency 

• Use a specific currency 

• From the Project Editor, click Information to edit the currency settings 

• Prices are pulled from the catalog before applying the conversion 

• Update currency prior to making any price adjustments at the item level 

 
ACTIVITY A.5 - APPLY A CURRENCY TO A PROJECT 

1. From the Project Editor, click Information. The Information window will open. 

2. In the General section, choose a different currency. 

3. Click the Check Conversion Rate Online option to update the rate. 

4. Click Save and Close. 
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 Change Currencies in a Service Order 
 

• If a default currency is set for a Client, a Service Order will inherit it 

• Currency must be changed prior to adding items to a Service Order 

• The conversion rate can be updated in the Service Order 

• The new conversion rate will only apply to items added after the rate change 

• All Products and Labor will use the active currency 

 

ACTIVITY A.6 - CHANGE CURRENCIES IN A SERVICE ORDER 

1. From the Service Order Explorer, click New. 

2. In the new Service Order, choose a Client. 

Note: If the Client has a default currency, it will update the currency in the SO. 

3. Adjust the currency as necessary. 

4. Click the Check Conversion Rate Online option to update the rate. 

5. Add details to the Service Order as you normally would. 
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 Manage Currencies in a Purchase Order 
 

• If a default currency is set for a Vendor, a Purchase Order will inherit it 

• Currency must be changed prior to adding items to a Purchase Order 

• The conversion rate can be updated in the Purchase Order 

• The new conversion rate will only apply to items added after the rate change 

• All Products will use the active currency 
 

ACTIVITY A.7 - CHANGE CURRENCIES IN A PURCHASE ORDER 

1. From the Purchase Order Explorer, click New. 

2. In the new Purchase Order, choose a Vendor. 

Note: If the Vendor has a default currency, it will update the currency in the PO. 

3. Adjust the currency as necessary. 

4. Click the Check Conversion Rate Online option to update the rate. 

5. Add details to the Purchase Order as you normally would. 
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Appendix B: 
Workflow Rules and Notifications 

 
This content was developed to provide an introduction to Workflow Rules. 

Topics 

• Overview of Workflow Rules 

• Define your Process First 

• Define your Team Roles 

• Creating Workflow Rules 

• Workflow Rule Examples  
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 Overview of Workflow Rules 
 

• Workflow Rules can be created for four entity types 

• Projects 

• Purchase Orders 

• Tasks 

• Service Orders 

• Workflow Rules 

• Trigger In App and e-mail Notifications (by entity, by role or specific 

user/e-mail) 

• Can place restrictions on editing and/or reporting 

• Can be triggered when an entity is created/updated/deleted or 

locked/unlocked 

• Execution criteria include status, cost, price, resource and other 

changes 
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 Define your Process First 
 

• A well-defined process can be one part of having an effective team 

• Larger teams require more structure and SI can help 

• Create a flowchart outlining steps and milestones for your projects 

• Customize the various status lists in SI 

• Use Project Status to leverage important project milestones 

• Match Purchase Order Status to your procurement process 

• Schedule Status should follow your scheduling, install and service 

process 
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ACTIVITY B.1 - CUSTOMIZE YOUR PROJECT STATUS LIST 

1. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

2. In the Project section, double-click Project Status. This opens the Manage Project Status window. 

3. To add a new status, Click New. 

4. Type a name for the Status and set a State. 

Note: States are Open, Won or Lost. All Statuses prior to contract should have the Open State. Statuses 

reflecting a project that was rejected, should have a State of Lost. All other Statuses should have the 

State set to Won. See Dashboards for more on using States. 

5. Use the Arrange buttons to reorder Statuses (Move Up/Move Down). 

6. Click Save and Close when finished. 
 

ACTIVITY B.2 - CUSTOMIZE YOUR ORDER STATUS LIST 

1. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

2. In the Project section, double-click Order Status. This opens the Manage Order Status window. 

3. To add a new status, Click New. 

4. Type a name for the Status. 

Note: POs set Order Status for project Items. If you create custom statuses for ordered items or received 

items, adjust the statuses appropriately in the bottom section of the window. 

5. Use the Arrange buttons to reorder Statuses (Move Up/Move Down). 

6. Click Save and Close when finished.  
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ACTIVITY B.3 - CUSTOMIZE YOUR SCHEDULE STATUS LIST 

1. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

2. In the Schedule section, double-click Schedule Status. This opens the Manage Schedule Status 

window. 

3. To add a new status, Click New. 

4. Type a name for the Status. 

Note: When using Mobile Install, an install status set to ‘In Progress’ or ‘Completed’ can be matched 

to custom Schedule Statuses. If you create custom Schedule Statuses, adjust the statuses appropriately 

in the bottom section of the window. 

5. Use the Arrange buttons to reorder Statuses (Move Up/Move Down). 

6. Click Save and Close when finished. 
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 Define your Team Roles 
 

• SI allows for users to be assigned to one or more roles 

• Custom roles can be created to define as many roles as necessary 

• Notifications can be sent to users of a specific role who are associated to an 

entity 

• This allows Workflow Rules to be user agnostic 

• If a user changes roles, the Workflow Rules continue to function 

 

ACTIVITY B.4 - ADD USER ROLES 

6. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

7. In the User section, double-click Users. This opens the Manage Users window. 

8. Click on the Roles button. The Manage Roles window opens. 

9. Click New to add roles. 

10. Click Save and Close when finished. 

11. Double-click on a User record to open for editing. 

12. Find the Roles drop-down menu and select one or more roles for the user. 

13. Click Save and Close when finished. 
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 Creating Workflow Rules 
 

• All Workflow Rules have common elements 

• First, choose the entity to create a rule (Project, PO, Task, SO) 

• Next, choose the Execute On option 

• When entity is Created, Updated, Deleted 

• When entity or the entity’s reports are Locked/Unlocked 

• Then provide criteria to filter the triggering of the rule (choose one or more) 

• Filter to a specific User, User Role, Status or other changes 

• Criteria options will vary based on the entity chosen 

• See the SI Support Wiki for full details: Workflow Rules Criteria 

• Select Users to Notify, add others via email, and type a message to display 

• Finally, and optionally, set Actions to Lock the entity and/or reports 
  

https://support.d-tools.com/000_SI_Documentation/Administrator_Guide/04_Setup/02_Control_Panel/Workflow_Rules#Criteria
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 Workflow Rule Examples 
 

• Request for Quote – Sales creates a project with scope of work and budget, 

then sets Project Status to “Request for Quote” 

• Notify Sales Manager of Project Margin below minimum % 

• Assign PM to Project – Notify the Ops Manager when a project is approved 

• SO needs to be scheduled – User creates SO and sets Status “Needs to be 

scheduled” 

• SO Ready to Invoice – Status set to “Ready to Invoice” after being reviewed for 

accuracy 

• PO Issued/Received – Notify PM when PO status is Issued/Received (works 

with single PM) 
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ACTIVITY B.5 - CREATE A PROJECT WORKFLOW TO PROMPT THE OPS MANAGER TO ASSIGN A 

PM TO A NEW JOB 

Note: This workflow assumes you have a Project Status labeled ‘Approved’ or a similar status used to 

identify when a project is won. 

6. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

7. In the Application section, double-click Workflow Rules. This opens the Manage Workflow Rules 

window. 

8. Click on the New button. The Select Entity window opens. 

9. Select the Project radio button and choose OK. 

10. In the Execute On section, choose ‘Update’. 

11. Type a name for the rule. 

12. In the Criteria section, check ‘Status’ and then choose ‘Approved’ from the drop-down menu. 

13. Click the Notify tab. 

14. In the SI Users section, click Add. The Add Users window opens. 

15. Then choose one or more users from the list. Click Add. 

16. Click Save and Close when finished. 
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ACTIVITY B.6 - CREATE A PROJECT WORKFLOW TO PROMPT THE SALES MANAGER WHEN THE 

MARGIN FOR A PROJECT DROPS BELOW A MINIMUM THRESHOLD 

1. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

2. In the Application section, double-click Workflow Rules. This opens the Manage Workflow Rules 

window. 

3. Click on the New button. The Select Entity window opens. 

4. Select the Project radio button and choose OK. 

5. In the Execute On section, choose ‘Update’. 

6. Type a name for the rule. 

7. In the Criteria section 

a. check ‘Margin’ 

b. Choose ‘Less Than’ from the drop-down menu 

c. Enter a minimum percent to trigger the rule 

8. Click the Notify tab. 

9. In the SI Users section, click Add. The Add Users window opens. 

10. Then choose one or more users from the list. Click Add. 

11. Click Save and Close when finished. 
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ACTIVITY B.7 - CREATE A SERVICE ORDER WORKFLOW TO PROMPT THE ACCOUNTING TEAM 

WHEN A SERVICE ORDER HAS BEEN REVIEWED AND IS READY TO INVOICE 

Note: This workflow assumes you have a Schedule Status labeled ‘Ready to Invoice’ or a similar status. 

1. Starting from the SI application, click Setup → Control Panel. The Control Panel opens. 

2. In the Application section, double-click Workflow Rules. This opens the Manage Workflow Rules 

window. 

3. Click on the New button. The Select Entity window opens. 

4. Select the Service Order radio button and choose OK. 

5. In the Execute On section, choose ‘Update’. 

6. Type a name for the rule. 

7. In the Criteria section, check ‘Status’ and then choose ‘Ready to Invoice’ from the drop-down menu. 

8. Click the Notify tab. 

9. In the SI Users section, click Add. The Add Users window opens. 

10. Then choose one or more users from the list. Click Add. 

11. Click Save and Close when finished. 
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D-Tools Training and Support Resources 
 

• Questions? 
 
 
 

• Support Resources Available 

• D-Tools Application Home Page Links 

• Documentation – open the Support Wiki 

• Support Ticket – open the web page to create a support ticket 

• Chat With Us – Launches Chat Support 

• From any D-Tools software interface, click Learn More 

• Found in the upper-right corner 

• Launches the Support Wiki 

• Open the Support Wiki directly at support.d-tools.com 

• Send an email to support@d-toolshelp.com 

• Call 866.386.6571 

 

http://support.d-tools.com/001_SI_2017_Documentation
http://d-tools.com/open-a-support-ticket/
http://messenger.providesupport.com/messenger/dtools.html
http://support.d-tools.com/
mailto:support@d-toolshelp.com
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